import re
regex = re.compile(r"(?:(?:\+\(?[0-9]{1,3}|\(?\b[0-9]{4})\)?)?\h*\)?[-\h.]?\(?[0-9]{1,3}\)?[-\h.]?[0-9]{3}[-\h.]?[0-9]{3,4}", flags=re.MULTILINE)
test_str = ("+1555555555\n"
"+4974339296\n"
"+591 74339296\n"
"+1 555 555 5554\n"
"+(591) 7433433\n"
"+(591) (4) 6434850\n"
"0591 74339296\n"
"0001 5555555555\n"
"(0001) 5555555\n"
"59145678464\n\n"
"3298494333")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")