#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)Q \d\. .*?(?=\n\nQ \d\.|$)"
Local $sString = "Q 1. What is your age?" & @CRLF & _
"" & @CRLF & _
"Ans. 15." & @CRLF & _
"" & @CRLF & _
"Q 2. What is your name?" & @CRLF & _
"" & @CRLF & _
"Ans. My name is Bond. " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"My full name is James Bond" & @CRLF & _
"" & @CRLF & _
"Q 3. What is your favorite subject?"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")