import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Q \\d\\. .*?(?=\\n\\nQ \\d\\.|$)";
final String string = "Q 1. What is your age?\n\n"
+ "Ans. 15.\n\n"
+ "Q 2. What is your name?\n\n"
+ "Ans. My name is Bond. \n\n\n"
+ "My full name is James Bond\n\n"
+ "Q 3. What is your favorite subject?";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}