re = /Q \d\. .*?(?=\n\nQ \d\.|$)/
str = 'Q 1. What is your age?
Ans. 15.
Q 2. What is your name?
Ans. My name is Bond.
My full name is James Bond
Q 3. What is your favorite subject?'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end