$re = '/Q \d\. .*?(?=\n\nQ \d\.|$)/s';
$str = 'Q 1. What is your age?
Ans. 15.
Q 2. What is your name?
Ans. My name is Bond.
My full name is James Bond
Q 3. What is your favorite subject?';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);