use strict;
my $str = 'Q 1. What is your age?
Ans. 15.
Q 2. What is your name?
Ans. My name is Bond.
My full name is James Bond
Q 3. What is your favorite subject?';
my $regex = qr/Q \d\. .*?(?=\n\nQ \d\.|$)/sp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}