using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"email.+?\b(\S+@\S+)";
string input = @"here is some text
that does not hi_there@welcome.co
but this email should be captured yes-well@well.com";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}