re = /email.+?\b(\S+@\S+)/
str = 'here is some text
that does not hi_there@welcome.co
but this email should be captured yes-well@well.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end