$re = '/email.+?\b(\S+@\S+)/';
$str = 'here is some text
that does not hi_there@welcome.co
but this email should be captured yes-well@well.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);