const regex = /email.+?\b(\S+@\S+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('email.+?\\b(\\S+@\\S+)', 'g')
const str = `here is some text
that does not hi_there@welcome.co
but this email should be captured yes-well@well.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}