package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`email.+?\b(\S+@\S+)`)
var str = `here is some text
that does not hi_there@welcome.co
but this email should be captured yes-well@well.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}