#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!\s*(\/\/|\/\*|\*\/|\*)).*for each\s*\(\s*var\s+(\w+)\s+in\s+(\w+)\s*\)\s*\{\s*([\s\S]*?)\s*\}"
Local $sString = "for each (var device in devices) {...}" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" fqwf f qw fqw for each (var device in devices) {...}" & @CRLF & _
"" & @CRLF & _
"// for each (var device in devices) {...}" & @CRLF & _
"" & @CRLF & _
"* for each (var device in devices) {...}" & @CRLF & _
"" & @CRLF & _
"/* for each (var device in devices) {...}" & @CRLF & _
"" & @CRLF & _
"*/ for each (var device in devices) {...} // Yeah this fails.."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")