re = /^(?!\s*(\/\/|\/\*|\*\/|\*)).*for each\s*\(\s*var\s+(\w+)\s+in\s+(\w+)\s*\)\s*\{\s*([\s\S]*?)\s*\}/m
str = 'for each (var device in devices) {...}
fqwf f qw fqw for each (var device in devices) {...}
// for each (var device in devices) {...}
* for each (var device in devices) {...}
/* for each (var device in devices) {...}
*/ for each (var device in devices) {...} // Yeah this fails..'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end