const regex = /^(?!\s*(\/\/|\/\*|\*\/|\*)).*for each\s*\(\s*var\s+(\w+)\s+in\s+(\w+)\s*\)\s*\{\s*([\s\S]*?)\s*\}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!\\s*(\\\/\\\/|\\\/\\*|\\*\\\/|\\*)).*for each\\s*\\(\\s*var\\s+(\\w+)\\s+in\\s+(\\w+)\\s*\\)\\s*\\{\\s*([\\s\\S]*?)\\s*\\}', 'gm')
const str = `for each (var device in devices) {...}
fqwf f qw fqw for each (var device in devices) {...}
// for each (var device in devices) {...}
* for each (var device in devices) {...}
/* for each (var device in devices) {...}
*/ for each (var device in devices) {...} // Yeah this fails..`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}