$re = '/^(?!\s*(\/\/|\/\*|\*\/|\*)).*for each\s*\(\s*var\s+(\w+)\s+in\s+(\w+)\s*\)\s*\{\s*([\s\S]*?)\s*\}/m';
$str = 'for each (var device in devices) {...}
fqwf f qw fqw for each (var device in devices) {...}
// for each (var device in devices) {...}
* for each (var device in devices) {...}
/* for each (var device in devices) {...}
*/ for each (var device in devices) {...} // Yeah this fails..';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);