import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!\\s*(\\/\\/|\\/\\*|\\*\\/|\\*)).*for each\\s*\\(\\s*var\\s+(\\w+)\\s+in\\s+(\\w+)\\s*\\)\\s*\\{\\s*([\\s\\S]*?)\\s*\\}";
final String string = "for each (var device in devices) {...}\n\n\n"
+ " fqwf f qw fqw for each (var device in devices) {...}\n\n"
+ "// for each (var device in devices) {...}\n\n"
+ "* for each (var device in devices) {...}\n\n"
+ "/* for each (var device in devices) {...}\n\n"
+ "*/ for each (var device in devices) {...} // Yeah this fails..";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}