using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!\s*(\/\/|\/\*|\*\/|\*)).*for each\s*\(\s*var\s+(\w+)\s+in\s+(\w+)\s*\)\s*\{\s*([\s\S]*?)\s*\}";
string input = @"for each (var device in devices) {...}
fqwf f qw fqw for each (var device in devices) {...}
// for each (var device in devices) {...}
* for each (var device in devices) {...}
/* for each (var device in devices) {...}
*/ for each (var device in devices) {...} // Yeah this fails..";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}