using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\d+ \d+ obj$(?:(?!^\d+ \d+ obj$)[\s\S])*?@mail[\s\S]*?^endobj$";
string input = @"12 12 obj
<<
Some content here
>>
endobj
12 13 obj
<<
Some content here with a email address that contains @mail.
>>
endobj
11 12 obj
<<
Some more content here
>>
endobj
124 126 obj
<<
Some content here
Another Line too
>>
endobj
12 16 obj
<<
Some content here
Another Line
Another Line
An @mail address.
>>
endobj";
RegexOptions options = RegexOptions.Singleline | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}