$re = '/^\d+ \d+ obj$(?:(?!^\d+ \d+ obj$)[\s\S])*?@mail[\s\S]*?^endobj$/sm';
$str = '12 12 obj
<<
Some content here
>>
endobj
12 13 obj
<<
Some content here with a email address that contains @mail.
>>
endobj
11 12 obj
<<
Some more content here
>>
endobj
124 126 obj
<<
Some content here
Another Line too
>>
endobj
12 16 obj
<<
Some content here
Another Line
Another Line
An @mail address.
>>
endobj';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);