# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^\d+ \d+ obj$(?:(?!^\d+ \d+ obj$)[\s\S])*?@mail[\s\S]*?^endobj$"
test_str = ("12 12 obj\n"
"<<\n"
"Some content here\n"
">>\n"
"endobj\n"
"12 13 obj\n"
"<<\n"
"Some content here with a email address that contains @mail.\n"
">>\n"
"endobj\n"
"11 12 obj\n"
"<<\n"
"Some more content here\n"
">>\n"
"endobj\n"
"124 126 obj\n"
"<<\n"
"Some content here\n"
"Another Line too\n"
">>\n"
"endobj\n"
"12 16 obj\n"
"<<\n"
"Some content here\n"
"Another Line\n"
"Another Line\n"
"An @mail address.\n"
">>\n"
"endobj")
matches = re.finditer(regex, test_str, re.DOTALL | re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.