use strict;
my $str = '12 12 obj
<<
Some content here
>>
endobj
12 13 obj
<<
Some content here with a email address that contains @mail.
>>
endobj
11 12 obj
<<
Some more content here
>>
endobj
124 126 obj
<<
Some content here
Another Line too
>>
endobj
12 16 obj
<<
Some content here
Another Line
Another Line
An @mail address.
>>
endobj';
my $regex = qr/^\d+ \d+ obj$(?:(?!^\d+ \d+ obj$)[\s\S])*?@mail[\s\S]*?^endobj$/smp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}