const regex = /^\d+ \d+ obj$(?:(?!^\d+ \d+ obj$)[\s\S])*?@mail[\s\S]*?^endobj$/gsm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\d+ \\d+ obj$(?:(?!^\\d+ \\d+ obj$)[\\s\\S])*?@mail[\\s\\S]*?^endobj$', 'gsm')
const str = `12 12 obj
<<
Some content here
>>
endobj
12 13 obj
<<
Some content here with a email address that contains @mail.
>>
endobj
11 12 obj
<<
Some more content here
>>
endobj
124 126 obj
<<
Some content here
Another Line too
>>
endobj
12 16 obj
<<
Some content here
Another Line
Another Line
An @mail address.
>>
endobj`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}