import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\d+ \\d+ obj$(?:(?!^\\d+ \\d+ obj$)[\\s\\S])*?@mail[\\s\\S]*?^endobj$";
final String string = "12 12 obj\n"
+ "<<\n"
+ "Some content here\n"
+ ">>\n"
+ "endobj\n"
+ "12 13 obj\n"
+ "<<\n"
+ "Some content here with a email address that contains @mail.\n"
+ ">>\n"
+ "endobj\n"
+ "11 12 obj\n"
+ "<<\n"
+ "Some more content here\n"
+ ">>\n"
+ "endobj\n"
+ "124 126 obj\n"
+ "<<\n"
+ "Some content here\n"
+ "Another Line too\n"
+ ">>\n"
+ "endobj\n"
+ "12 16 obj\n"
+ "<<\n"
+ "Some content here\n"
+ "Another Line\n"
+ "Another Line\n"
+ "An @mail address.\n"
+ ">>\n"
+ "endobj";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}