using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?<!!)[A-Z]{1,2}[0-9]";
string substitution = @"sheet_turnover!$0";
string input = @"=+(sheet_factory_costs!A17/sheet_employees!D23)+T12+W12
=+(sheet_factory_costs!A17 / sheet_employees!D23)+sheet_turnover!T12+sheet_turnover!W12";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}