const regex = /\b(?<!!)[A-Z]{1,2}[0-9]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?<!!)[A-Z]{1,2}[0-9]', 'g')
const str = `=+(sheet_factory_costs!A17/sheet_employees!D23)+T12+W12
=+(sheet_factory_costs!A17 / sheet_employees!D23)+sheet_turnover!T12+sheet_turnover!W12`;
const subst = `sheet_turnover!$0`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);