re = /\b(?<!!)[A-Z]{1,2}[0-9]/
str = '=+(sheet_factory_costs!A17/sheet_employees!D23)+T12+W12
=+(sheet_factory_costs!A17 / sheet_employees!D23)+sheet_turnover!T12+sheet_turnover!W12'
subst = 'sheet_turnover!$0'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result