import Foundation
let pattern = #"\b(?<!!)[A-Z]{1,2}[0-9]"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
=+(sheet_factory_costs!A17/sheet_employees!D23)+T12+W12
=+(sheet_factory_costs!A17 / sheet_employees!D23)+sheet_turnover!T12+sheet_turnover!W12
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"sheet_turnover!$0"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)