use strict;
my $str = '=+(sheet_factory_costs!A17/sheet_employees!D23)+T12+W12
=+(sheet_factory_costs!A17 / sheet_employees!D23)+sheet_turnover!T12+sheet_turnover!W12';
my $regex = qr/\b(?<!!)[A-Z]{1,2}[0-9]/p;
my $subst = 'sheet_turnover!$0';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";