#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(^[^a-zA-Z0-9]+)|([^a-zA-Z0-9]+$)"
Local $sString = "!@#$abc-123-4;5.def)(*&^;_" & @CRLF & _
"!@#$abc-123-4;5.def)(*&^;" & @CRLF & _
"!@#$abc-123-4;5.def)_(*&^;_" & @CRLF & _
"!@#$nabc-123-4;5.def)_(*&^;_" & @CRLF & _
"!@#$abc-123-4;5.def)_(*&^;_" & @CRLF & _
"abc-123-4;5.def"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")