using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^[^a-zA-Z0-9]+)|([^a-zA-Z0-9]+$)";
string input = @"!@#$abc-123-4;5.def)(*&^;_
!@#$abc-123-4;5.def)(*&^;
!@#$abc-123-4;5.def)_(*&^;_
!@#$nabc-123-4;5.def)_(*&^;_
!@#$abc-123-4;5.def)_(*&^;_
abc-123-4;5.def";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}