$re = '/(^[^a-zA-Z0-9]+)|([^a-zA-Z0-9]+$)/m';
$str = '!@#$abc-123-4;5.def)(*&^;_
!@#$abc-123-4;5.def)(*&^;
!@#$abc-123-4;5.def)_(*&^;_
!@#$nabc-123-4;5.def)_(*&^;_
!@#$abc-123-4;5.def)_(*&^;_
abc-123-4;5.def';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);