re = /(^[^a-zA-Z0-9]+)|([^a-zA-Z0-9]+$)/m
str = '!@#$abc-123-4;5.def)(*&^;_
!@#$abc-123-4;5.def)(*&^;
!@#$abc-123-4;5.def)_(*&^;_
!@#$nabc-123-4;5.def)_(*&^;_
!@#$abc-123-4;5.def)_(*&^;_
abc-123-4;5.def'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end