package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^[^a-zA-Z0-9]+)|([^a-zA-Z0-9]+$)`)
var str = `!@#$abc-123-4;5.def)(*&^;_
!@#$abc-123-4;5.def)(*&^;
!@#$abc-123-4;5.def)_(*&^;_
!@#$nabc-123-4;5.def)_(*&^;_
!@#$abc-123-4;5.def)_(*&^;_
abc-123-4;5.def`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}