// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(^[^a-zA-Z0-9]+)|([^a-zA-Z0-9]+$)").unwrap();
let string = "!@#$abc-123-4;5.def)(*&^;_
!@#$abc-123-4;5.def)(*&^;
!@#$abc-123-4;5.def)_(*&^;_
!@#$nabc-123-4;5.def)_(*&^;_
!@#$abc-123-4;5.def)_(*&^;_
abc-123-4;5.def";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}