const regex = /([A-Za-z]{2,4})([a-zA-Z0-9\-\_ ]{2,12})/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([A-Za-z]{2,4})([a-zA-Z0-9\\-\\_ ]{2,12})', 'g')
const str = `IT12345678901
NL123456789B01
ESX1234567X
ATUU12345678
FI1234567-9
HU 12345678
DE_123456789
AAAAAAAAAAA
AAA aaaaaa
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}