$re = '/([A-Za-z]{2,4})([a-zA-Z0-9\-\_ ]{2,12})/';
$str = 'IT12345678901
NL123456789B01
ESX1234567X
ATUU12345678
FI1234567-9
HU 12345678
DE_123456789
AAAAAAAAAAA
AAA aaaaaa
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);