// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"([A-Za-z]{2,4})([a-zA-Z0-9\-\_ ]{2,12})").unwrap();
let string = "IT12345678901
NL123456789B01
ESX1234567X
ATUU12345678
FI1234567-9
HU 12345678
DE_123456789
AAAAAAAAAAA
AAA aaaaaa
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}