using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([^a-zA-Z\d])?(?P<file_id>[\-a-zA-Z]{3}[\-a-zA-Z\d]{5,15}H?)([^a-zA-Z\d].*)?\.(?P<file_ext>mov|mpg|mxf|mp4)$";
string input = @"GOOG6998000H.mov";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}