$re = '/^([^a-zA-Z\d])?(?P<file_id>[\-a-zA-Z]{3}[\-a-zA-Z\d]{5,15}H?)([^a-zA-Z\d].*)?\.(?P<file_ext>mov|mpg|mxf|mp4)$/m';
$str = 'GOOG6998000H.mov';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);