re = /^([^a-zA-Z\d])?(?P<file_id>[\-a-zA-Z]{3}[\-a-zA-Z\d]{5,15}H?)([^a-zA-Z\d].*)?\.(?P<file_ext>mov|mpg|mxf|mp4)$/m
str = 'GOOG6998000H.mov'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end