import re
regex = re.compile(r'^([^a-zA-Z\d])?(?P<file_id>[\-a-zA-Z]{3}[\-a-zA-Z\d]{5,15}H?)([^a-zA-Z\d].*)?\.(?P<file_ext>mov|mpg|mxf|mp4)$', flags=re.MULTILINE)
test_str = "GOOG6998000H.mov"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")