#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<!not\s)(?<!isn't\s)(?:great|good)"
Local $sString = " "great words"," & @CRLF & _
" "not great words"," & @CRLF & _
""words good", # Words before phrase" & @CRLF & _
" "words not good"," & @CRLF & _
" "words isn't good""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")