import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!not\\s)(?<!isn't\\s)(?:great|good)";
final String string = " \"great words\",\n"
+ " \"not great words\",\n"
+ "\"words good\", # Words before phrase\n"
+ " \"words not good\",\n"
+ " \"words isn't good\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}