$re = '/(?<!not\s)(?<!isn\'t\s)(?:great|good)/m';
$str = ' "great words",
"not great words",
"words good", # Words before phrase
"words not good",
"words isn\'t good"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);