using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!not\s)(?<!isn't\s)(?:great|good)";
string input = @" ""great words"",
""not great words"",
""words good"", # Words before phrase
""words not good"",
""words isn't good""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}