const regex = new RegExp('(?<!not\\s)(?<!isn\\'t\\s)(?:great|good)', 'gm')
const str = ` "great words",
"not great words",
"words good", # Words before phrase
"words not good",
"words isn't good"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}