re = /(?<!not\s)(?<!isn't\s)(?:great|good)/m
str = ' "great words",
"not great words",
"words good", # Words before phrase
"words not good",
"words isn\'t good"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end