#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=Sent: Monday, |Tuesday, |Wednesday, |Thursday, |Friday, |Saturday, |Sunday, )(\d\d\s|\d\s)(January |February |March |April |May |June |July |August |September |October |November |December )(20\d\d)"
Local $sString = "From: john@workplace.com" & @CRLF & _
"Sent: Thursday, 23 May 2019 7:14 AM" & @CRLF & _
"To: Team Inbox" & @CRLF & _
"Subject: Send me some more cookies"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")