const regex = /(?<=Sent: Monday, |Tuesday, |Wednesday, |Thursday, |Friday, |Saturday, |Sunday, )(\d\d\s|\d\s)(January |February |March |April |May |June |July |August |September |October |November |December )(20\d\d)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=Sent: Monday, |Tuesday, |Wednesday, |Thursday, |Friday, |Saturday, |Sunday, )(\\d\\d\\s|\\d\\s)(January |February |March |April |May |June |July |August |September |October |November |December )(20\\d\\d)', 'gm')
const str = `From: john@workplace.com
Sent: Thursday, 23 May 2019 7:14 AM
To: Team Inbox
Subject: Send me some more cookies`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}