import re
regex = re.compile(r"(?<=Sent: Monday, |Tuesday, |Wednesday, |Thursday, |Friday, |Saturday, |Sunday, )(\d\d\s|\d\s)(January |February |March |April |May |June |July |August |September |October |November |December )(20\d\d)", flags=re.MULTILINE)
test_str = ("From: john@workplace.com\n"
"Sent: Thursday, 23 May 2019 7:14 AM\n"
"To: Team Inbox\n"
"Subject: Send me some more cookies")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")